Running Omnisci tests locally

I’m trying to run the omnisci db tests locally to check my PR (https://github.com/modin-project/modin/pull/2744), but can’t seem to install the omniscidbe4py package using Conda. I’m working off of a 2017 MacBook Pro running macOS Mojave (10.14.6). I tried creating a Conda environment using modin/requirements/env_omnisci.yml, found here, as well as installing it from the following channels:

  • intel
  • intel/label/modin
  • intel/label/modintest
  • intel/label/oneapibeta

When I try and install from the channels, I get a PackageNotFoundError, and when I try installing using the yml file, I get the following error:
Collecting package metadata (repodata.json): done
Solving environment: failed
ResolvePackageNotFound:
- ray-core[version=’>=1.0.0,<1.2.0’]
- omniscidbe4py
I was hoping to get some help installing the omnisci package so I could debug locally!

I’m afraid currently there is no ray-core package for Mac…

That makes sense! Would installing Ray normally work too? Additionally, do you have any recommendation for how I can get around the package not found error for omniscidbe4py?

The most important - unfortunately omniscidbe4py is only for Linux at the moment.

I think your best bet for now would be aquiring either a virtual machine or a docker container with Linux inside where you could install omniscidbe4py and all other stuff.

@vnlitvinov Can we create a docker container for such use cases?

@devin-petersohn yes, we can. I take it upon myself.

1 Like

Thank you! I’ll go ahead and review the PR for Modin-core!

1 Like

We are trying on CentOS 7.9… getting the same error: Does omniscidbe4py work on Conda 3.8 version of python?

conda install -c intel/label/modin omniscidbe4py
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: -
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with the existing python installation in your environment:

Specifications:

  • omniscidbe4py → python=3.7
  • omniscidbe4py → python[version=’>=3.7,<3.8.0a0’]

Your python: python=3.8

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify
that.

The following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.17=0
  • feature:|@/linux-64::__glibc==2.17=0
  • omniscidbe4py → __glibc[version=’>=2.17,<3.0.a0’]

Your installed version is: 2.17

@raokakarlamudi , currently omnisci backend supports python 3.7 only. We merged a docker file for omnisci backend development into master. You can find it here.

Thank you. We went past python step but still are getting __glibc issue… we do have 2.17 version.

Will try to move higher version and let you know if it works. Thanks

1 Like