Error importing Modin

Trying to install Modin. It looks like an issue with my version of pandas which is 1.4.2 (the latest).

Here’s the Error
ImportError: cannot import name ‘NDFrameT’ from ‘pandas._typing’

**Here’s some context

  • Running this on Databricks
  • Working from their notebook

Code I’m running
!pip install “modin[dask]”
import pandas as pd
import modin.pandas as pd

(Output of pipdeptree)**
Warning!!! Possibly conflicting dependencies found:

  • PyGObject==3.36.0
  • pycairo [required: >=1.11.1, installed: ?]

modin==0.14.1

  • fsspec [required: Any, installed: 2022.5.0]
  • numpy [required: >=1.18.5, installed: 1.20.1]
  • packaging [required: Any, installed: 20.9]
    • pyparsing [required: >=2.0.2, installed: 2.4.7]
  • pandas [required: ==1.4.2, installed: 1.4.2]
    • numpy [required: >=1.18.5, installed: 1.20.1]
    • python-dateutil [required: >=2.8.1, installed: 2.8.1]
      • six [required: >=1.5, installed: 1.15.0]
    • pytz [required: >=2020.1, installed: 2020.5]

@JohnV thank you for posting here! I can’t reproduce the error on my mac in a fresh conda environment. Would you be able to provide:

  • The Databricks notebook you are using
  • operating system information
  • The python version
  • the full stack trace of the ImportError